Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-12-2008, 06:16 PM   #1
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Question Onan just quit

This concerns our 1990 345LE MH with Onan 6.5 NHE Emerald 3.

After it quit running here's what I've checked in order:

1. Both fuses at gen-set, OK
2. Engine turns over fine.
3. Good spark.
4. Removed air cleaner and gave quick shot of start fluid. It then started right up but only for an instant.
5. Removed fuel inlet line at carb, cranked eng. and no fuel. (DRY)
6. Removed supply hose at fuel pump and was wet.
7. Unplugged fuel pump 12V. connector at pump and found no feed to pump.
I dont know where this 12V. feed wire originates. DOES ANYONE ELSE KNOW where I should check next before I start taking things apart ??
Any other fuses involved ?

I would guess that it would involve direct to battery 12V. somewhere, I just dont know where. Considering the vehicle ignition switch position doesn't affect the Onan squashes my knowledge of electric fuel pump on this one. Thanks...
__________________

__________________
345bill is offline   Reply With Quote
Old 12-12-2008, 08:07 PM   #2
Rivet Master
Airstream Dealer
 
Inland RV Center, In's Avatar
 
Corona , California
Join Date: Feb 2002
Posts: 16,499
Images: 1
Quote:
Originally Posted by 345bill View Post
This concerns our 1990 345LE MH with Onan 6.5 NHE Emerald 3.

After it quit running here's what I've checked in order:

1. Both fuses at gen-set, OK
2. Engine turns over fine.
3. Good spark.
4. Removed air cleaner and gave quick shot of start fluid. It then started right up but only for an instant.
5. Removed fuel inlet line at carb, cranked eng. and no fuel. (DRY)
6. Removed supply hose at fuel pump and was wet.
7. Unplugged fuel pump 12V. connector at pump and found no feed to pump.
I dont know where this 12V. feed wire originates. DOES ANYONE ELSE KNOW where I should check next before I start taking things apart ??
Any other fuses involved ?

I would guess that it would involve direct to battery 12V. somewhere, I just dont know where. Considering the vehicle ignition switch position doesn't affect the Onan squashes my knowledge of electric fuel pump on this one. Thanks...
You maybe looking for a problem that you don't have.

All generators have a separate fuel line coming from the fuel tank.

That "dip tube" does not go to the bottom of the tank, but only about 3/4 of the way, by design.

Therefore if the fuel tank is not full enough or if the coach is parked on an angle, then you just cannot feed any fuel to the system.

Add 20 or 30 gallons of fuel to the tank, and I believe the problem will go away.

The design is such that if your running the GEN, you cannot deplete the entire fuel supply.

Andy
__________________

__________________
Inland RV Center, In is offline   Reply With Quote
Old 12-13-2008, 10:59 AM   #3
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Quote:
Originally Posted by Inland RV Center, In View Post
You maybe looking for a problem that you don't have.

All generators have a separate fuel line coming from the fuel tank.

That "dip tube" does not go to the bottom of the tank, but only about 3/4 of the way, by design.

Therefore if the fuel tank is not full enough or if the coach is parked on an angle, then you just cannot feed any fuel to the system.

Add 20 or 30 gallons of fuel to the tank, and I believe the problem will go away.

The design is such that if your running the GEN, you cannot deplete the entire fuel supply.

Andy
Andy-
The Onan has previously run out of fuel when the MH guage shows a little than 1/2 tank. I didn't mention the fuel tank is presently full.
Am I correct in thinking the Onan's electric fuel pump must have constant 12V. feed ?
The red wire coming out of pump has a male push in connector and the female connector that it plugs into does not have any voltage.
Isn't this the 12V. supply wire ? Or am I missing something ? Thanks
__________________
345bill is offline   Reply With Quote
Old 12-13-2008, 11:13 AM   #4
Rivet Master
Airstream Dealer
 
Inland RV Center, In's Avatar
 
Corona , California
Join Date: Feb 2002
Posts: 16,499
Images: 1
Quote:
Originally Posted by 345bill View Post
Andy-
The Onan has previously run out of fuel when the MH guage shows a little than 1/2 tank. I didn't mention the fuel tank is presently full.
Am I correct in thinking the Onan's electric fuel pump must have constant 12V. feed ?
The red wire coming out of pump has a male push in connector and the female connector that it plugs into does not have any voltage.
Isn't this the 12V. supply wire ? Or am I missing something ? Thanks
I don't have any schematics at home.

The fuel pump must operate to provide fuel for the generator.

Andy
__________________
Inland RV Center, In is offline   Reply With Quote
Old 12-13-2008, 12:31 PM   #5
Full Timers/Diesel power.
 
Mike Leary's Avatar
 
1983 31' Airstream310
Cactus Hug , Arizona
Join Date: Mar 2007
Posts: 2,540
Images: 11
When was the last time the fuel and air filter was replaced?
__________________
"A settled wisdom, plus the itch to be elsewhere"
Mike Leary is offline   Reply With Quote
Old 12-13-2008, 02:55 PM   #6
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Quote:
Originally Posted by Mike Leary View Post
When was the last time the fuel and air filter was replaced?
Mike- The in-line filter and air filter are less than 1 yr. old. I just sent you a message on Dick's water pump thread before I read this one from you. Thanks
__________________
345bill is offline   Reply With Quote
Old 12-13-2008, 03:23 PM   #7
Full Timers/Diesel power.
 
Mike Leary's Avatar
 
1983 31' Airstream310
Cactus Hug , Arizona
Join Date: Mar 2007
Posts: 2,540
Images: 11
Hope this helps; spark plug? My guys have told me the solid-state ignition in
the later Onan units is junk. That linkage could be the problem. So could be the battery cable running back to the gen set be trashed and not putting out enough to fire it.
Attached Thumbnails
Click image for larger version

Name:	DSCN1888.jpg
Views:	126
Size:	200.7 KB
ID:	72545  
__________________
"A settled wisdom, plus the itch to be elsewhere"
Mike Leary is offline   Reply With Quote
Old 12-13-2008, 04:10 PM   #8
The Hawk's Lair
 
cooperhawk's Avatar
 
1985 34.5' Airstream 345
BACK WOODS , Minnesota
Join Date: Dec 2002
Posts: 922
Images: 9
There is also a low oil cut off. Check the oil level of the genset.
__________________
AKA THE GUNNER
There is no "I" in the word "team," but there are four in "Platitude Quoting Idiot!"

AIRSTREAM 345 TURBO-DIESEL
VFW, LEGION, NRA


cooperhawk is offline   Reply With Quote
Old 12-13-2008, 04:13 PM   #9
The Hawk's Lair
 
cooperhawk's Avatar
 
1985 34.5' Airstream 345
BACK WOODS , Minnesota
Join Date: Dec 2002
Posts: 922
Images: 9
I have the manuals for a 1985 model scanned. If you need them I can e-mail them to you.
__________________
AKA THE GUNNER
There is no "I" in the word "team," but there are four in "Platitude Quoting Idiot!"

AIRSTREAM 345 TURBO-DIESEL
VFW, LEGION, NRA


cooperhawk is offline   Reply With Quote
Old 12-13-2008, 04:36 PM   #10
Full Timers/Diesel power.
 
Mike Leary's Avatar
 
1983 31' Airstream310
Cactus Hug , Arizona
Join Date: Mar 2007
Posts: 2,540
Images: 11
Hope all you guys have these hr. meters.
Attached Thumbnails
Click image for larger version

Name:	DSCN1891.jpg
Views:	115
Size:	127.1 KB
ID:	72546  
__________________
"A settled wisdom, plus the itch to be elsewhere"
Mike Leary is offline   Reply With Quote
Old 12-13-2008, 05:13 PM   #11
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Quote:
Originally Posted by Mike Leary View Post
Hope this helps; spark plug? My guys have told me the solid-state ignition in
the later Onan units is junk. That linkage could be the problem. So could be the battery cable running back to the gen set be trashed and not putting out enough to fire it.
Mike- You're right on when you asked if I can hear it powering up.

That clicking sound that all electric fuel pumps make is not present. That is why I checked for 12V. and found 0 at the pump.

Shows good spark at plug and will run momentarily if I manually prime carb. Thanks
__________________
345bill is offline   Reply With Quote
Old 12-13-2008, 05:41 PM   #12
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Quote:
Originally Posted by cooperhawk View Post
I have the manuals for a 1985 model scanned. If you need them I can e-mail them to you.
Gunner- Oil level is OK. Now that you mention it seems I remember reading elsewhere on thse forums someone else had similar problem and it turned out to be faulty low oil sw. I will search for that post.

Appreciate the e-mail offer but I think I have the manual around home somewhere, if I can remember where I put it. I'll let you know. Thanks
__________________
345bill is offline   Reply With Quote
Old 12-13-2008, 08:38 PM   #13
Rivet Master
 
bkahler's Avatar

 
1974 20' Argosy 20
Richmond , Kentucky
Join Date: Jan 2003
Posts: 6,348
Bill,

I might be wrong but I thought the power for the electric fuel pump came from the same place power to the coil comes from.

Just a thought.

Brad
__________________
Air forums # 1674
1974 20' Argosy Motor Home
1974 31' Excella trailer (parting out, as of 4/1/2015 I have wheels, brake drums, windows & holding tanks left to sell)
bkahler is offline   Reply With Quote
Old 12-13-2008, 10:23 PM   #14
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
Quote:
Originally Posted by bkahler View Post
Bill,

I might be wrong but I thought the power for the electric fuel pump came from the same place power to the coil comes from.

Just a thought.

Brad
Brad-
And a excellent thought that is. Seeing that it will run momentarily if I manually prime carb, a temporary jumper from coil to fuel pump pos. wire sounds like my next logical step. Thanks
__________________

__________________
345bill is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I quit Smoking RichardT Off Topic Forum 404 01-27-2015 10:54 PM
We Quit ericinrb 2005 and newer - Bambi all models 99 07-19-2009 12:16 AM
'96 LY fridge quit working airstream96 Land Yacht/Legacy Motorhomes 5 07-02-2007 10:05 PM
Water Heater Quit again carnegie1935 Water Heaters, Filters & Pumps 5 03-20-2007 07:56 PM
**Chris Quit Blinking At Me** Silvertwinky Our Community 6 09-02-2003 12:11 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.