Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-13-2008, 11:19 PM   #15
Rivet Master
 
bkahler's Avatar

 
1974 20' Argosy 20
Richmond , Kentucky
Join Date: Jan 2003
Posts: 6,354
Quote:
Originally Posted by 345bill View Post
Brad-
And a excellent thought that is. Seeing that it will run momentarily if I manually prime carb, a temporary jumper from coil to fuel pump pos. wire sounds like my next logical step. Thanks
On vehicles with electric fuel pumps I think the power feed also goes through an oil pressure switch. If there is low oil pressure while the engine is running the fuel pump shuts off. During starting this switch is bypassed to allow the engine to start. I'm wondering if your generator might be set up the same way and something is wrong with the start bypass switch or its contacts.

Bottom line is you should be able to run a +12 vdc hot wire to your fuel pump to see if it runs. If it does then you just have to back track the wiring to the pump itself.

Good luck!

Brad
__________________

__________________
Air forums # 1674
1974 20' Argosy Motor Home
1974 31' Excella trailer (parting out, as of 4/1/2015 I have wheels, brake drums, windows & holding tanks left to sell)
bkahler is offline   Reply With Quote
Old 12-19-2008, 06:47 PM   #16
Rivet Master
 
345bill's Avatar
 
Las Vegas , Nevada
Join Date: Apr 2007
Posts: 608
ONAN UPDATE:
I think it was a combination of problems. Running a jumper wire direct to fuel pump pos. did make the pump start "clicking", however it still would not pump fuel, even when I put the fuel inlet hose into a full gas can. So I went to Onan parts house and bought a pump, oil pressure sw., oil and filter.
Came home and it snowed all day so I impatiently waited until today.
Anyway it is dry out today so I installed all above parts plus 4' of fuel hose and new in-line filter.
Had a smile from ear to ear when it fired right up and just purrres.
So THANKS to EVERYONE for your input, now back to the list of other items needing attention.
__________________

__________________
345bill is offline   Reply With Quote
Old 12-20-2008, 07:59 AM   #17
Rivet Master
 
bkahler's Avatar

 
1974 20' Argosy 20
Richmond , Kentucky
Join Date: Jan 2003
Posts: 6,354
Bill,

Happy to hear you got it going again. Sounds like it was probably the pressure switch causing you the most grief.

Brad
__________________

__________________
Air forums # 1674
1974 20' Argosy Motor Home
1974 31' Excella trailer (parting out, as of 4/1/2015 I have wheels, brake drums, windows & holding tanks left to sell)
bkahler is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I quit Smoking RichardT Off Topic Forum 404 01-27-2015 10:54 PM
We Quit ericinrb 2005 and newer - Bambi all models 99 07-19-2009 12:16 AM
'96 LY fridge quit working airstream96 Land Yacht/Legacy Motorhomes 5 07-02-2007 10:05 PM
Water Heater Quit again carnegie1935 Water Heaters, Filters & Pumps 5 03-20-2007 07:56 PM
**Chris Quit Blinking At Me** Silvertwinky Our Community 6 09-02-2003 12:11 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.