Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2015, 09:11 PM   #1
2 Rivet Member
 
morlach's Avatar
 
Join Date: May 2014
Posts: 45
Let's Talk About Cruise Control in Classics

I have a 325 Classic 454ci P30. It has a cruise control in it, but it does not work. I am thinking that it would probably be simpler and more effective in the long run to just replace the system. Thoughts? Repair or replace. Bear in mind that I do not yet know exactly what is wrong with the existing one.
__________________

__________________
morlach is offline   Reply With Quote
Old 03-20-2015, 11:11 PM   #2
Rivet Master
 
Smartstream's Avatar

 
1982 28' Airstream 280
Port Angeles , Washington
Join Date: Aug 2008
Posts: 1,372
Quote:
Originally Posted by morlach View Post
I have a 325 Classic 454ci P30. It has a cruise control in it, but it does not work. I am thinking that it would probably be simpler and more effective in the long run to just replace the system. Thoughts? Repair or replace. Bear in mind that I do not yet know exactly what is wrong with the existing one.
I bought a control unit from Rostra. It is all electric and replaces the vacuum unit. The original control and speedo pick up work with it. All I had to do was mount it and connect it to the throttle linkage and connect the wires.
__________________

__________________
Cheers, Dan
________________________________________


"Socialist governments traditionally do make a financial mess. They always run out of other people's money. It's quite a characteristic of them."
~ Margaret Thatcher ~
Smartstream is offline   Reply With Quote
Old 03-21-2015, 11:30 AM   #3
Rivet Master
 
mayco's Avatar

 
1982 31' Airstream 310
champaign , Illinois
Join Date: Jun 2013
Posts: 2,766
Mine is also a Rostra after market.
__________________
mayco is offline   Reply With Quote
Old 03-21-2015, 01:23 PM   #4
Rivet Master
 
1982 28' Airstream 280
Redwood City , California
Join Date: Mar 2008
Posts: 1,735
I have the original vacuum cruise control and it worked fine until about a year and a half ago. I would like to get it working again. There's no money for me to replace it and with the limited miles I drive it, replacing it would not be feasible. I was hoping it was just a fuse but no luck.


Sent from my iPhone using Airstream Forums
__________________
http://projectupdraft.com/airstream

"We are free to go where we wish and to be what we are"
Richard Bach, Jonathan Livingston Seagall
dadstoy is offline   Reply With Quote
Old 03-22-2015, 12:55 PM   #5
4 Rivet Member
 
1977 31' Sovereign
Lynnwood , Washington
Join Date: Jan 2015
Posts: 311
I presume youi're talking mid-1980's vintage.

If it is, the transducer is usually the culprit. There's two speedo cables that attach to the transducer: one goes to the transmission; the other goes to the speedometer.

Transducer can be sent to a speedo shop for repair. Or, remove transducer and liberally apply WD-40 to both speedo cable connections.

Tom
__________________
TomKirk is offline   Reply With Quote
Old 03-22-2015, 02:21 PM   #6
Slowpoke
 
Gnorts's Avatar
 
2012 27' Flying Cloud
Portland , Oregon
Join Date: Dec 2013
Posts: 255
Your CC is probably repairable. That vintage is pretty basic, made up of components that you can likely find on eBay. Here's a piece from eBay that identifies the components and gives you some ideas on troubleshooting. The vacuum motor is easy to troubleshoot by any repair shop with a simple vacuum pump.

How to Test Your Cruise Control | eBay
__________________
Like the tortoise, travelin' slow with the house on our back
2012 FC27FB "Ted Zeppelin"
2010 Tundra Crewmax Platinum "Silver Rhino"
Gnorts is offline   Reply With Quote
Old 03-23-2015, 10:17 AM   #7
Rivet Master
 
m.hony's Avatar
 
2013 30' Classic
Greenwood , Mississippi
Join Date: Oct 2012
Posts: 11,833
I found a control module/black box for a 1995 G20 van in a junk yard that fixed the cruise control, but that was in 1999.
__________________

__________________
2013 Classic 30 Limited
2007 Silver Toyota Tundra Crew Max Limited 5.7 iForce
2006 Vivid Black Harley-Davidson Road King Classic
1999 Black Nissan Pathfinder LE
TAC #MS-10
WBCCI #1811, Region 6, Unit 56
Airforums #70955
m.hony is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Let's talk about Amazon some more... AIR-Quarius On The Road... 16 01-05-2015 04:05 PM
Let's talk Boundary Waters Caryl On The Road... 42 08-05-2009 01:05 PM
Let's Talk Batteries IrishRover2 Batteries, Univolts, Converters & Inverters 58 04-02-2007 02:24 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.