Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2012, 09:22 AM   #1
2 Rivet Member
 
Tomball , Texas
Join Date: May 2012
Posts: 61
'73 sov' cant get water heater pilot lit...

I've been able to get all other gas appliances working on this trailer since I bought it, but can't seem to get the pilot even lit on this water heater. The shut off valve is open under the trailer, pilot button depressed and I'm fairly sure I can faintly smell the gas, but when I put a flame to it....nothing. Any suggestions.

I attached a pic just incase anyone can spot any thing wrong visibly.
Attached Thumbnails
Click image for larger version

Name:	image-370358765.jpg
Views:	74
Size:	537.8 KB
ID:	160223  
__________________
TxBxSx is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.