Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-14-2019, 10:11 PM   #1
2 Rivet Member
 
alymorales's Avatar
 
2005 25' International CCD
Mission Hills , Kansas
Join Date: Oct 2011
Posts: 41
Micro Pulse Systems Monitor

My camper hasn't been out of storage in awhile. I went to check my water and battery levels and my monitor isn't working. Luckily, the pump switch still works. Any ideas on how to fix or does it need to be replaced? Click image for larger version

Name:	20191014_121117.jpeg
Views:	18
Size:	69.6 KB
ID:	354282
__________________

alymorales is offline   Reply With Quote
Old 10-15-2019, 12:44 AM   #2
Rivet Master
 
Foiled Again's Avatar
 
2012 25' FB Eddie Bauer
Vintage Kin Owner
Virginia Beach , Virginia
Join Date: Sep 2004
Posts: 6,768
Middle button is OFF
__________________

__________________
Today is a gift, that's why they call it the present.
Foiled Again is offline   Reply With Quote
Old 10-15-2019, 12:58 AM   #3
Rivet Master
 
ROBERTSUNRUS's Avatar

 
2005 25' Safari
Salem , Oregon
Join Date: Mar 2006
Posts: 7,801
Images: 18
Blog Entries: 55
Hi, this is not a good system; Mine was fixed several times. Now hasn't worked for about ten years. As I said before I owned a 1959 Ford and all of the original gauges worked great, but my 2005 Airstream gauges don't work. Spend some money and have the system changed [different brand] or do like me, do without gauges.
__________________
Bob

2005 Safari 25-B
"Le Petit Chateau Argent"
[ Small Silver Castle ]
2000 Navigator / 2014 F-150 Eco-Boost / Equal-i-zer / P-3
YAMAHA 2400 / AIR #12144
ROBERTSUNRUS is offline   Reply With Quote
Old 10-15-2019, 12:27 PM   #4
2 Rivet Member
 
alymorales's Avatar
 
2005 25' International CCD
Mission Hills , Kansas
Join Date: Oct 2011
Posts: 41
@ foiled again, I flipped the switch to on. Still no lights.
alymorales is offline   Reply With Quote
Old 10-16-2019, 10:20 AM   #5
Stay CazuaL
 
cazual6's Avatar
 
2018 25' Flying Cloud
2014 19' Flying Cloud
Reseda , California
Join Date: Aug 2014
Posts: 772
Images: 1
Quote:
Originally Posted by Foiled Again View Post
Middle button is OFF
That would be too funny and easy....hahahahahaha.
__________________
"No job is so simple that it cannot be done wrong."
"Everyone is entitled to be stupid, but some abuse the privilege."
"Either I will find a way, or I will make one."
WBCCI 9164
https://www.facebook.com/groups/2284022111820203/
cazual6 is offline   Reply With Quote
Old 10-16-2019, 10:27 AM   #6
Vantair
 
Vantair's Avatar
 
2005 25' International CCD
Westlake Village , California
Join Date: Sep 2014
Posts: 301
Images: 2
Maybe check blade fuses in Converter area ?
Or removing the Micropulse panel which has connections on back or something loose ? (Shut off “use” switch 1st before removing as the MP circuit board can touch the inner metal skin when removing.
__________________
Relaxing is hard work.
Vantair
2005 25ft International CCD SS
2014 GMC Sierra Denali 1500 4X4 int. 3.43 Int sway/tow controller
1981 Honda Trail CT110 1X0..no sway control
Vantair is offline   Reply With Quote
Old 10-16-2019, 10:36 AM   #7
Married with Airstream
 
drbrick's Avatar

 
2004 25' International CCD
Vancouver Island , British Columbia
Join Date: Apr 2018
Posts: 267
Images: 2
mine still work 2004 model but in reality it a crap shoot
__________________
La Dolce Vita Brick & Mona
2004 International 25CCD Registered Name "Blue Streak"
2013 F-150HD SuperCrew FX4 Lariart (MaxTow) "Red Dragon"

Married With Airstream Blog Click Here
Blog Languages: English/French/Spanish
drbrick is offline   Reply With Quote
Old 10-16-2019, 12:13 PM   #8
Rivet Master
 
2002 19' Bambi
Lafayette , California
Join Date: May 2005
Posts: 960
Several years after buying our 2002 new, I changed to the Micropulse system. It may have worked right for a month or two. Last year I replaced the Micropulse mess with the SeeLevel system. What a change! Consistent readings every time.

Tim
Tim A. is offline   Reply With Quote
Old 10-16-2019, 01:36 PM   #9
2 Rivet Member
 
VeloBuckeye's Avatar

 
2018 27' Flying Cloud
Easton , Pennsylvania
Join Date: May 2019
Posts: 32
Tim A — do you experience wide fluctuations with your SeeLevel readings? For example, the black tank will read 13%, then 23% after a quick flush. Seems to happen more often than not. Will have it looked at during my warranty trip to JC next spring, but I’m curious if this happens to you? BTW, I’m fanatic about treating/cleaning the tanks on a routine basis.
__________________
VeloBuckeye
2018 Flying Cloud 27FB
2018 F150 Lariat PowerStroke Diesel
VeloBuckeye is offline   Reply With Quote
Old 10-16-2019, 03:46 PM   #10
Rivet Master
 
2002 19' Bambi
Lafayette , California
Join Date: May 2005
Posts: 960
I don't see fluctuations like that. Starting at empty, our graywater gauge shows that the tank is filling faster (percentage-wise) than is correct. That is not a problem with the sender or gauge. The sender is on the deep end of the wedge-shaped tank bottom and that wedge fills quickly.

Tim
Tim A. is offline   Reply With Quote
Old 10-16-2019, 03:53 PM   #11
Rivet Master
 
dznf0g's Avatar
 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 10,349
Images: 5
Quote:
Originally Posted by VeloBuckeye View Post
Tim A ó do you experience wide fluctuations with your SeeLevel readings? For example, the black tank will read 13%, then 23% after a quick flush. Seems to happen more often than not. Will have it looked at during my warranty trip to JC next spring, but Iím curious if this happens to you? BTW, Iím fanatic about treating/cleaning the tanks on a routine basis.
Since the bottom of both the gray and black tank are sloped for draining, the first 5 gallons or so will show high readings. Mine shows empty when it is. Just adding digester and maybe 1/2 gallon of water with it will show 13%. 23% will show after a flush or two...then it becomes consistent after the level covers the sloped tank floor. The important thing is a consistent and accurate reading from, say 50% to 100% on the black and gray.
Opposite for fresh tank.
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-16-2019, 04:24 PM   #12
Moderator
 
jcanavera's Avatar

 
2004 30' Classic Slideout
Fenton , Missouri
Join Date: Mar 2002
Posts: 9,307
Images: 143
Send a message via AIM to jcanavera Send a message via Skype™ to jcanavera
The Micropluse system originally had a 5 year warranty by the manufacturer. They sent me a new one when I contacted them about a burnt out LED. Since then I've lost another LED, the black tank always shows full and fresh water level is out of calibration along with the grey water. I've lived with it this way long enough that personally it's not worth the effort to expense. Typically with my experience with travel trailers, the water monitoring systems have always been the first component failures with any travel trailer I've owned.

As far as your problem, it may be as simple as a poor connection into the panel. It uses telephone type wire which is terminated into a jack that is plugged into the panel. It might be worth pulling it off the wall and checking to make sure all the connections into the panel get unplugged and then plugged back in.

Jack
__________________

__________________
Jack Canavera
STL Mo.
AIR #56
'04 Classic 30' S.O.,'03 GMC Savana 2500,'14 Honda CTX 700
jcanavera is offline   Reply With Quote
Reply

« dealer cost | Top | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Micro Pulse Systems Monitor Bluto Electronics & Connectivity 40 11-08-2017 09:27 AM
Micro Pulse Systems Monitor Calbration Ponyfvr 2009-2015 Flying Cloud 1 10-30-2014 04:17 PM
micro pulse systems monitor Snedwid LP Gas, Piping, Tanks & Regulators 9 08-13-2012 11:21 AM
Micro Pulse Probeless Systems Monitor - How to Operate Colonial Airstream Commercial Listings 7 01-05-2012 09:28 AM
Micro-Pulse Systems Monitor Bites the Dust Wayne&Sam General Repair Forum 22 08-25-2011 09:04 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
×