Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-20-2015, 11:21 AM   #1
New Member
 
2014 Interstate Coach
Powell , Ohio
Join Date: Jul 2015
Posts: 3
TVs stopped working...

First off, hello all! We recently purchased a new (old stock) 2014, but I have been reading these forums for months. I apologize if my question is a dumb one - I have to admit that I am very much still learning the systems in this, our first RV. I wasn't able to walk through the vehicle with the dealer, and sometimes I find the manuals a little confusing.

So here goes: we took our first real road trip yesterday, 16 hours to Florida. We were cruising with the refer full of waters and sandwiches, and the 4 rugrats in the back. Maybe 4 or 5 hours in, the kids were getting a little restless, so we put a movie on each television. Both worked fine for the duration of that first movie. Shortly thereafter, the two older kids were playing playstation on the overhead set and the babies were watching another dvd in the back. First the overhead television shut down, then the rear one quit maybe a minute later. The refrigerator worked the entire time.

So I guess my question is did I flip a breaker or what? Should I not expect the inverter to run these items while rolling down the road? When we stopped once I fired up the generator real quick, and they still wouldn't come on. A/C worked fine though. I was thinking the inverter would power the outlets (TVs) and the refer while rolling down the road. Did I assume incorrectly or just overload the system or what? We are enjoying a little beach time with the kids before the rain hits, but I plan to dig in further this afternoon.

Sorry for the long post and the newbie questions. I tried to search and read the manuals, but I must be a little dense or something. Thanks everybody!

Rob
__________________

__________________
MVequalsPQ is offline   Reply With Quote
Old 07-20-2015, 11:53 AM   #2
4 Rivet Member
 
2011 Interstate Coach
Muskogee , Oklahoma
Join Date: Mar 2011
Posts: 452
Sounds like your alternator is not keeping the house batteries charged on the road. That's the first thing to check. What was the house battery charge level when it started shutting things down?

I don't know how they are wiring the AD/DC fridge in the 2014, but if they changed it, and wired it the way it should have been wired, it will run on 12vdc when not connected to shore power. If that's the case, it may have continued to operate, while power may have been selectively turned off power by the AC controller, possibly?

Connect to shore power, and see if everything works again. Check the battery charge to make sure they are fully charged and then disconnect and run on the inverter with the engine on or while driving. Do the batteries discharge or remain charged while driving with the inverter on?

If not, this will give you a clue what is causing the problem (which is likely a loose connection on the positive terminal on the isolator or the positive bus bar near the house battery that goes to the positive terminal on the isolator. Both are very easy to fix. Mine was a loose connection on the bus, so the house batteries would sometimes charge, and sometimes not, until it came so loose it was never would charge at all, leading me to have to figure out why.
__________________

__________________
2011 Interstate WD/Lounge
gmillerok1 is offline   Reply With Quote
Old 07-20-2015, 11:54 AM   #3
Rivet Master
 
UKDUDE's Avatar
 
2014 Interstate Ext. Coach
Sedona , Arizona
Join Date: Jul 2008
Posts: 1,038
Hello Rob, welcome to the forum.
I believe you have 2 GFCI's which you might want to check in case either has tripped: one is on the power distribution box under the rear sofa. On mine the GFCI is on the left of the box. Also you have another GFCI behind the driver's seat next to the second row passenger seat on the wall.
Good luck!
__________________
UKDUDE is offline   Reply With Quote
Old 07-20-2015, 01:01 PM   #4
Rivet Master
 
Boxster1971's Avatar

 
2013 Interstate Coach
Fulton , Maryland
Join Date: May 2010
Posts: 2,262
Although the TVs should not overload the Inverter it sounds like that is what happened to you. It happened to me once. I accidentally tripped the circuit breaker on my Magnum inverter by using one of the TV outlets for a hot pot. All circuits tied to the inverter stopped working even on the generator or shore power. I had to drop the rear panel under the lounge to get to the inverter to reset the breaker. BTW that is how you can easily get to the electronics under the lounge seat/bed. Just remove the black fabric cover plus a few screws and the rear panel drops down.


- - Mike
2013 Interstate Lounge EXT on 2012 Sprinter
__________________
- - Mike
--------------------------
2013 Airstream Interstate Lounge EXT
Boxster1971 is offline   Reply With Quote
Old 07-20-2015, 01:51 PM   #5
New Member
 
2014 Interstate Coach
Powell , Ohio
Join Date: Jul 2015
Posts: 3
Thanks! Definitely gives me a few things to check out this afternoon. Would sure be nice to get it figured out before the 1000 miles home!

I was just making sure that I wasn't off base by thinking the TVs could run w/o running the generator. Like I said, I am totally green.

Rob
__________________
MVequalsPQ is offline   Reply With Quote
Old 07-20-2015, 06:21 PM   #6
Rivet Master
 
73shark's Avatar
 
2011 Interstate Coach
Overland Park , Kansas
Join Date: Aug 2011
Posts: 2,748
I had the same problem last week on our return trip from Florida where all of the AC outlets dropped out at the same time. After checking all the breakers and the GFI outlet under the lounge I came back to the forum and fortunately someone there pointed out that the hidden outlet under the driver side passenger 2nd row seat has a GFI outlet which for some unknown reason Airstream decided to put upstream of all the outlets. Not sure what the logic was that dictated the placement of a GFI outlet in a hidden location like that. But then that's how Airstream rolls.
__________________
Glass half full or half empty to an engineer is the glass is twice as big as it needs to be.

PM me for sale info on my 2011. SOLD!
Upfitted Transit 350 sitting in driveway.
73shark is offline   Reply With Quote
Old 07-21-2015, 12:45 PM   #7
Rivet Master
 
Boxster1971's Avatar

 
2013 Interstate Coach
Fulton , Maryland
Join Date: May 2010
Posts: 2,262
Good point on that GFI outlet that one got me a few times too.


- - Mike
2013 Interstate Lounge EXT on 2012 Sprinter
__________________
- - Mike
--------------------------
2013 Airstream Interstate Lounge EXT
Boxster1971 is offline   Reply With Quote
Old 07-21-2015, 12:59 PM   #8
Figment of My Imagination
 
Protagonist's Avatar
 
2012 Interstate Coach
From All Over , More Than Anywhere Else
Join Date: Dec 2011
Posts: 10,306
Quote:
Originally Posted by Boxster1971 View Post
Good point on that GFI outlet that one got me a few times too.
Ditto. It's even worse when you find out that it tripped because someone who looks a lot like me— but obviously isn't me because I wouldn't do that— accidentally pressed the "Test" switch on the outlet by stacking something up against it while loading the van for an outing.
__________________
WBCCI #1105
TAC LA-4

My Google-Fu is strong today.
Protagonist is offline   Reply With Quote
Old 07-22-2015, 04:57 AM   #9
New Member
 
2014 Interstate Coach
Powell , Ohio
Join Date: Jul 2015
Posts: 3
That's exactly what it was. Not sure how it got tripped, but I'm sure glad it was that easy to fix. Thanks again for your help!

Rob
__________________

__________________
MVequalsPQ is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISH 2 TVs rear not working Wisconsinden General Repair Forum 2 01-14-2014 12:25 AM
Dometic has stopped working on AC? Pacerized Refrigerators 6 04-21-2009 08:28 PM
Porch light stopped working MK 1967 Lights - Interior & Exterior 5 08-24-2008 10:15 AM
The furnace stopped working ipso_facto Furnaces, Heaters, Fireplaces & Air Conditioning 13 02-24-2006 03:04 PM
Tail Lights Stopped Working dpope 2003 Safari 8 04-05-2003 01:22 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.