Thread Tools Search this Thread Display Modes
Old 04-27-2015, 02:03 PM   #1
1 Rivet Member
2012 Interstate Coach
Key West , Florida
Join Date: May 2013
Posts: 5
Holding tank pump stopped working

I was pumping out my holding tanks and the pump just stopped working. Where do I start to try and fix the situation ? I did not run it dry and have always been careful not to do that. Please help!

Key West is offline   Reply With Quote
Old 04-27-2015, 02:20 PM   #2
Rivet Master
UKDUDE's Avatar
2014 Interstate Ext. Coach
Sedona , Arizona
Join Date: Jul 2008
Posts: 846
First place to check is for a blown fuse. I'm not sure if the fuse positions in your Interstate are the same as mine, but in mine, you look inside the 12 volt distribution panel and check Circuit 9, 20 amp fuse color tan.
Otherwise it could be the macerator pump is jammed due to large particles clogging it. To free it, there's a slot for a flat-blade screwdriver on the end of the pump.
Check the fuse first though.

UKDUDE is offline   Reply With Quote
Old 04-27-2015, 03:17 PM   #3
3 Rivet Member
Mjgman's Avatar
2013 Interstate Coach
Bradenton , Florida
Join Date: Jul 2014
Posts: 183
If it does have a clog as mine did ( daughter putting paper towels in the toilet) it kept blowing the fuse.. I used a ratchet with a flat head screw driver attachment and an extender, it was much easier to pump out manually till it was free enough to go on its own without blowing the fuse..
Mjgman is offline   Reply With Quote
Old 04-28-2015, 06:44 AM   #4
1 Rivet Member
2012 Interstate Coach
Key West , Florida
Join Date: May 2013
Posts: 5
Thanks for the help.... I will try the above and see where it takes me.
Key West is offline   Reply With Quote
Old 04-28-2015, 11:04 AM   #5
New Member
Spicewood , Texas
Join Date: Dec 2014
Posts: 2
My pump stopped. Cleaned strainer near top of pump. Poured approx a cup of water to prime the pump and it is OK now.
lwb9 is offline   Reply With Quote
Old 04-28-2015, 03:00 PM   #6
Figment of My Imagination
Protagonist's Avatar
2012 Interstate Coach
Metairie , Louisiana
Join Date: Dec 2011
Posts: 9,085
Originally Posted by lwb9 View Post
My pump stopped. Cleaned strainer near top of pump. Poured approx a cup of water to prime the pump and it is OK now.
Welcome to the AirForums! Good to have you with us.

Just a bit of clarification for you, the OP was talking about a macerator pump on an Airstream Interstate, used to pump out the black and gray tanks through a glorified garden hose since we don't have a slinky on late-model Interstates.

But even though you were talking about a different kind of pump, it's great that your first post was an offer of advice to help with a problem. Most us us start with a "Hi, this is who I am" post, then a bunch of "Help, I have a problem" posts, before we graduate to the "Here's how I fixed that problem you're having" posts. You're well ahead of the curve!
WBCCI #1105

Engineering: Finding complex solutions to simple problems you didn't even know you had.
Protagonist is offline   Reply With Quote
Old 04-30-2015, 10:17 PM   #7
2 Rivet Member
lamato's Avatar
2013 Interstate Coach
Sacramento , California
Join Date: Jul 2012
Posts: 78
Once, when I thought the pump wasn't working, it was just because I had forgotten to flip the switch above the sink. I hope that makes sense and your problem is as simple as that.

Sent from my iPad using Airstream Forums

lamato is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Holding the door open, when stopped Maggiefoss Doors & Locks 5 02-13-2011 12:35 AM
Dometic has stopped working on AC? Pacerized Refrigerators 6 04-21-2009 07:28 PM
Porch light stopped working MK 1967 Lights - Interior & Exterior 5 08-24-2008 09:15 AM
The furnace stopped working ipso_facto Furnaces, Heaters, Fireplaces & Air Conditioning 13 02-24-2006 02:04 PM
Tail Lights Stopped Working dpope 2003 Safari 8 04-05-2003 12:22 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:10 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.