Thread Tools Search this Thread Display Modes
Old 09-10-2015, 01:44 PM   #1
2 Rivet Member
Blackpearl's Avatar
2014 Interstate Ext. Coach
Charlotte , North Carolina
Join Date: Sep 2015
Posts: 40
Help! Generator running but...

Oh man. Just got a 2014 AI last month and everything was going good until today. Generator turns on fine but will not distribute power. No AC no microwave, nothing will run off the gen now. At first I thought it was because the LPG was almost empty but after refilling it's still not powering anything. Even after running for 15 minutes. Checked breakers and fuses which seem to be fine. In the middle of a trip so it's a hard time to take it to get looked at. It's hot, hoping that it's something simple. Thanks!

Blackpearl is offline   Reply With Quote
Old 09-10-2015, 01:52 PM   #2
Rivet Master

Vintage Kin Owner
North central , Florida
Join Date: Jul 2005
Posts: 5,463
Do the Interstates have a master switch that could have been moved?

1984 Avion 30p 9.1 meter. 2006 Dodge 3500 cummins srw short bed crew cab.
avionstream is offline   Reply With Quote
Old 09-10-2015, 02:54 PM   #3
4 Rivet Member
toskeysam's Avatar
2013 Interstate Coach
Townsend , Tennessee
Join Date: Nov 2013
Posts: 376
The generator has its own output circuit breaker.....behind a maintenance panel on the generator....under the van. Check there if all other fuses and breakers are good.
FMCA # 436814
toskeysam is offline   Reply With Quote
Old 09-10-2015, 02:58 PM   #4
4 Rivet Member
2007 23' Safari SE
Fernandina Beach , Florida
Join Date: May 2013
Posts: 252
Right, remove the access panel (turn the single latch with a flathead screwdriver and lift up to remove) and then reach over the bottom edge of the opening to feel for the breaker which has a vertical orientation. Its a tad hard with one hand or the other, but you need to lay on your side to do this maneuver. Once you locate it, just flip it whichever way causes it to reset. The Onan runs with it tripped, but will not distribute power. Usually it will trip if you try too large a load on it before letting it warm up.
Tomzstream is offline   Reply With Quote
Old 09-10-2015, 04:51 PM   #5
1 Rivet Member
2012 Interstate Coach
Virginia Beach , Virginia
Join Date: Apr 2014
Posts: 11
Agree with all of the above, if that doesn't get it working then you may have a bad Automatic Transfer Switch. On my 2012 it's located in the very rear on driver side. It transfers shore or generator power to the coach, with the generator taking preference if both sources of power are available. I had a similar issue with my generator and it turned out to be this switch. It was under $100 to buy online and an easy DIY fix if you're out of warranty. Good Luck. JC

Sent from my iPad using Airstream Forums
Johnvabeach is offline   Reply With Quote
Old 09-11-2015, 07:41 AM   #6
3 Rivet Member
Dalwyn's Avatar
2015 Interstate Ext. Coach
Southaven , Mississippi
Join Date: Apr 2015
Posts: 176
Just make sure you are resetting the breaker. Dummy me, on a trip in the Blue Ridge parkway, overloaded the system and tripped the breaker. Crawled under and pushed what I thought was the breaker, started the gen still no power to any system. Once I got home and was able to see where the breaker was, determined I previously pushed the manual stop switch.
Dalwyn is offline   Reply With Quote
Old 09-11-2015, 11:31 AM   #7
2 Rivet Member
Blackpearl's Avatar
2014 Interstate Ext. Coach
Charlotte , North Carolina
Join Date: Sep 2015
Posts: 40
Thanks everyone! I have learned a lot. It was in fact a bad transfer switch and then discovered a few other issues. You all got me in the right direction.

Blackpearl is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Marquis 7000 running.. but... kboggs315 Land Yacht/Legacy Motorhomes 7 08-23-2016 04:07 PM
generator not running rsr2216 Land Yacht/Legacy Motorhomes 3 09-08-2012 01:32 PM
Running generator on propane JDS Electrical - Systems, Generators, Batteries & Solar 11 07-27-2012 12:56 PM
Dometic working on shore power, but difficult to get it running on gas Scott J-24 Refrigerators 28 12-22-2011 03:49 PM
Onan running but no power to a/c.... mossyoaks Electrical - Systems, Generators, Batteries & Solar 4 09-06-2010 08:29 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.