Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-30-2014, 05:29 PM   #1
1 Rivet Member
 
2014 Interstate Ext. Coach
Mont Saint Hilaire , Quebec
Join Date: Jul 2014
Posts: 6
AC not working with generator

Hello. We've had our 2014 AI for three weeks now (and this forum has been great help for us newbies). It's the first time we've tried running the AC with the generator (shore power disconnected). The generator is working correctly; however, the AC won't turn on. There is an error code ("E7") on the thermostat. Has anyone experienced the same and/or knows how to remedy the situation?

Thanks in advance,

Troy
__________________

__________________
PhaneufDuazo is offline   Reply With Quote
Old 07-30-2014, 05:47 PM   #2
Rivet Master
 
rodsterinfl's Avatar

 
2006 25' Safari
Fort Myers , Florida
Join Date: Oct 2011
Posts: 2,434
Images: 8
Here is the error code for Dometic:

***E7 Loss of 120 VAC power to all power module boards on the system. The system will shut down.
__________________

__________________
WBCCI 8653/AIR 60240
2017 Ford F-150 3.5 Ecobeast Gen 2 3.55 Platinum
rodsterinfl is offline   Reply With Quote
Old 07-30-2014, 06:01 PM   #3
Rivet Master
 
UKDUDE's Avatar
 
2014 Interstate Ext. Coach
Sedona , Arizona
Join Date: Jul 2008
Posts: 1,040
To rodsterinfl: This is an Interstate, so the generator and AC are all integrated by Airstream at build.
To PhaneufDuazo: When the generator is running, does the Power Control System display (in the overhead locker where you start the generator) have all green indicators for the 4 systems (W/H, AC, Coffee, Micro)? The don't come on straight away, it takes maybe 5 minutes for the generator to settle down and the Power Control System to enable everything.
__________________
UKDUDE is offline   Reply With Quote
Old 07-30-2014, 06:30 PM   #4
Rivet Master
 
rodsterinfl's Avatar

 
2006 25' Safari
Fort Myers , Florida
Join Date: Oct 2011
Posts: 2,434
Images: 8
Yes I picked up on that and only posted the error code.
__________________
WBCCI 8653/AIR 60240
2017 Ford F-150 3.5 Ecobeast Gen 2 3.55 Platinum
rodsterinfl is offline   Reply With Quote
Old 07-30-2014, 06:48 PM   #5
Rivet Master
 
Ron_CA's Avatar
 
2015 Interstate Ext. Coach
San Diego , California
Join Date: Feb 2014
Posts: 665
My AC did not work off of generator power at delivery either but I didn't have an E7 code on thermostat.

My Dealer did a reset by disconnecting the wires behind the Power Control System Display. They removed the 4 screws to remove the display and disconnected the 2 wires (what I was told by the tech that actually did the work) behind the display. Waited a few minutes and reconnected. Mine works perfectly now.

If you try this yourself and it doesn't work, don't tell anyone that you did it As it could affect your warranty.
__________________
Ron_CA is offline   Reply With Quote
Old 07-30-2014, 08:00 PM   #6
1 Rivet Member
 
2014 Interstate Ext. Coach
Mont Saint Hilaire , Quebec
Join Date: Jul 2014
Posts: 6
Thanks for the feedback. Will try your suggestions. Hope this works as our three-week shakedown tour starts on Friday!
__________________
PhaneufDuazo is offline   Reply With Quote
Old 07-31-2014, 10:57 PM   #7
2 Rivet Member
 
2014 Interstate Ext. Coach
Houston , Texas
Join Date: May 2014
Posts: 33
I had to take mine back to the dealership to get the AC repair and they said it was a fuse. It's still in the dealership after 3 weeks waiting for other parts.
__________________

__________________
Dungrace is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar or generator or and generator? badkat Full-Timing 15 11-17-2014 10:59 PM
Help! Battery not charging, outlets not working when plugged in AirGal04 Electrical - Systems, Generators, Batteries & Solar 9 06-06-2014 10:15 PM
pump not working... Chuck Water Heaters, Filters & Pumps 23 05-16-2007 10:44 AM
Microwave not working ViewRVs Airstream Motorhome Forums 4 08-28-2002 03:08 PM
vent fans missing/not working Rog0525 Roof Vents, Skylights & Fans 2 07-02-2002 05:23 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.