Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-25-2014, 02:48 PM   #1
1 Rivet Member
 
Ashburn , Virginia
Join Date: Feb 2013
Posts: 16
2014 AI EXT Rear view camera monitor problem

Hi all,
Suddenly my rear view camera monitor just stopped working. It seems that it doesn't get any power. The monitor is just dead. Does any one know if there is a fuse or some thing that I should check to see why it doesn't turn on? I was going to check if there is any connection problems right above the rear mirror where the wire from the rear view camera monitor goes under the roof panel but wanted to check if any one has any experience looking at the connections in this area.
The model is PLMC7200.

Thanks.
__________________

__________________
tishaeisha is offline   Reply With Quote
Old 05-25-2014, 03:41 PM   #2
Rivet Master
 
73shark's Avatar
 
2011 Interstate Coach
Overland Park , Kansas
Join Date: Aug 2011
Posts: 2,748
The Pyle monitor seems to have a history of a short life.

Mine failed in about 18 months. Same symptoms as yours. Of course it happened just as we were leaving on a trip. On the plus side, I got real good at using the side mirrors.
__________________

__________________
Glass half full or half empty to an engineer is the glass is twice as big as it needs to be.

PM me for sale info on my 2011. SOLD!
Upfitted Transit 350 sitting in driveway.
73shark is offline   Reply With Quote
Old 05-25-2014, 04:38 PM   #3
4 Rivet Member
 
David M's Avatar
 
2013 Interstate Coach
Orange County , California
Join Date: Apr 2013
Posts: 277
On mine, the power connection (plug) that's located in the overhead interior light cluster was loose. To get that light cluster off, sit in the passenger seat and push the overhead cover towards the driver seat while pulling down.
David
__________________
David M is offline   Reply With Quote
Old 05-25-2014, 08:05 PM   #4
2 Rivet Member
 
AtlantaCpl's Avatar
 
2013 Interstate Coach
Atlanta , Georgia
Join Date: Aug 2013
Posts: 47
Same issue here, and my advice

Mine failed within the first year. I had it on all the time and the circuitry just couldn't handle it. Since setting it to come on when in reverse only it seems to be ok.

The bad news is the monitors are cheap Chinese crap. The good news is they are also cheap on Amazon. I purchased one and switched out the monitor and all was fine.

I was told the same thing about going up through the map lights to get to it, and this is WAY more of a hassle and risky to break something than what I figured out. You can easily get to all the wires through the plastic CB/Accessory cover at the top. It was a snap to replace, took all of 15 minutes, with most of that being my anal nature to make sure and run wires better than the way they were done originally.

I'm actually thinking about picking up a spare or two of these things just in case it happens again. Companies go out of business all the time and it would be a royal pain to have to replace the camera in the back if this company ever went under.

Brian
__________________
AtlantaCpl is offline   Reply With Quote
Old 05-25-2014, 08:11 PM   #5
1 Rivet Member
 
Ashburn , Virginia
Join Date: Feb 2013
Posts: 16
I removed the overhead light cluster and wiggle the black round socket connection. After that the unit started working. It seems that it is a loose connection or broken wire inside the round connection socket. I need to open the connection and check it out tomorrow. David M, did you just have to tighten(push) the connection or repair it? Thanks.
__________________
tishaeisha is offline   Reply With Quote
Old 05-25-2014, 08:38 PM   #6
Rivet Master
 
73shark's Avatar
 
2011 Interstate Coach
Overland Park , Kansas
Join Date: Aug 2011
Posts: 2,748
Forgot to mentioned that mine was replaced by the dealer under warranty.

Pyle has been around a long time in the mobile electronics business.
__________________
Glass half full or half empty to an engineer is the glass is twice as big as it needs to be.

PM me for sale info on my 2011. SOLD!
Upfitted Transit 350 sitting in driveway.
73shark is offline   Reply With Quote
Old 05-25-2014, 09:40 PM   #7
4 Rivet Member
 
David M's Avatar
 
2013 Interstate Coach
Orange County , California
Join Date: Apr 2013
Posts: 277
Quote:
Originally Posted by tishaeisha View Post
I removed the overhead light cluster and wiggle the black round socket connection. After that the unit started working. It seems that it is a loose connection or broken wire inside the round connection socket. I need to open the connection and check it out tomorrow. David M, did you just have to tighten(push) the connection or repair it? Thanks.

I simply tied a knot out of the connector so that it tightens when pulled in. I did this about 6 months ago and it still works fine. Let me know if you don't know what I'm talking about and I'll take a picture of what I did. I also bought a spare display on Amazon for about $30 just in case. Good luck.
David
__________________
David M is offline   Reply With Quote
Old 05-25-2014, 09:54 PM   #8
4 Rivet Member
 
David M's Avatar
 
2013 Interstate Coach
Orange County , California
Join Date: Apr 2013
Posts: 277
Here's a picture of the "knot" I tied. This way, the connector will not pull apart when the wire is tugged on. Click image for larger version

Name:	ImageUploadedByAirstream Forums1401072836.336246.jpg
Views:	88
Size:	751.4 KB
ID:	212850
__________________
David M is offline   Reply With Quote
Old 05-26-2014, 09:30 AM   #9
1 Rivet Member
 
Ashburn , Virginia
Join Date: Feb 2013
Posts: 16
Thanks David. I am going to tie a knot like the way you did. As others have suggested, I am going to order an extra monitor from amazon, just in case.
__________________
tishaeisha is offline   Reply With Quote
Old 05-26-2014, 10:24 AM   #10
Rivet Master
 
UKDUDE's Avatar
 
2014 Interstate Ext. Coach
Sedona , Arizona
Join Date: Jul 2008
Posts: 1,037
This Pyle monitor has a mixed bag of reviews on Amazon with many rating it one star. Image quality is so poor and hard to see in sunlight. Has anyone changed it for something better?
__________________
UKDUDE is offline   Reply With Quote
Old 06-03-2014, 07:39 PM   #11
3 Rivet Member
 
denellen's Avatar
 
2007 25' International CCD
1964 19' Globetrotter
2012 Interstate Coach
vero beach , Florida
Join Date: Mar 2005
Posts: 184
Back up camera
I would like to replace the Pyle back up camera installed by AS. Has anyone found a better camera and monitor?
__________________
Dennis & Ellen

07, 25' Ocean Breeze
64, 19' Globetrotter

Air #7609
denellen is offline   Reply With Quote
Old 06-03-2014, 08:07 PM   #12
Rivet Master
 
Boxster1971's Avatar

 
2013 Interstate Coach
Fulton , Maryland
Join Date: May 2010
Posts: 2,256
Quote:
Originally Posted by denellen View Post
Back up camera
I would like to replace the Pyle back up camera installed by AS. Has anyone found a better camera and monitor?
Which Kenwood head unit do you have in your 2012 AI? Most, like my DNX7190, can be used as a rear view camera monitor. the DNX7190 can actually take two camera inputs. You can probably just use the existing camera. Is it is the Pioneer ND-BC5? That's what I have and it is a fairly good camera.

Only problem is you would only get camera view in reverse or when you select it on screen overriding the NAV or other displays.
__________________

__________________
- - Mike
--------------------------
2013 Airstream Interstate Lounge EXT
Boxster1971 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Swift Hitch Camera and Monitor Problem rustyrivet Audio, Video & TV 5 10-28-2014 11:07 PM
2014.5 interstate ext rear bed not folding flat Dungrace Sprinter and B-van Forum 25 06-19-2014 03:46 PM
Backup Camera as Rear View Camera Rapa Nui Tow Vehicles 10 07-10-2013 05:37 PM
Rear Monitor & Camera Advice spat61 General Motorhome Topics 12 12-26-2009 08:16 AM
Rear View Camera and Monitor. cooperhawk General Motorhome Topics 19 04-18-2008 05:10 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.