Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2016, 06:39 AM   #1
Rivet Master
 
Naper's Avatar
 
2017 30' Classic
Loretto , Ontario
Join Date: Oct 2010
Posts: 507
F250 Trailer Charge Dead

I have a 2017 F250, trailer charging from the 7 pin connector is not working. The fuse (30 amp #27) is good. Cant find the relay no mention of it in the owners manual. Trailer lights and brakes work.
__________________

Naper is offline   Reply With Quote
Old 10-23-2016, 07:32 AM   #2
2 Rivet Member
 
2011 27' FB Classic
Camp Hill , Pennsylvania
Join Date: Jul 2015
Posts: 75
I had the same issue. My Ford dealer went nuts finding what was wrong but eventually came up with a service note on it. There is no voltage on the truck pin unless there is a load on it. That's done so we don't short out the truck battery if snow or water gets into the connector. To prove this is correct measure the trailer battery voltage when disconnected. Then connect and start the truck. The voltage should be higher on the trailer battery.
__________________

LyleRussell is offline   Reply With Quote
Old 10-23-2016, 09:30 AM   #3
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 3,667
My 2006 F150 had a relay, at least it had a spot for a relay, but it was not installed. I bought the relay and my trailer charge port became active (but only when the engine was running).

On a lark, I dug up the manual for the 2017 F250:
http://www.fordservicecontent.com/Fo...ngEnabled=True
Fuse 27 says it powers the trailer tow charge relay
Item 37 is the relay

Maybe Canadian trucks are different



Al
__________________

"You cannot reason someone out of a position they have not been reasoned into"

Al, K5TAN and Missy, N4RGO
2002 Classic 30 Slideout
S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
2001 Safari 25 RB Twin (Gone, but not forgotten)
WBCCI 1322, TAC FL-39, AIR 82265

Al and Missy is offline   Reply With Quote
Old 10-23-2016, 10:48 AM   #4
Rivet Master
 
Naper's Avatar
 
2017 30' Classic
Loretto , Ontario
Join Date: Oct 2010
Posts: 507
[QUOTE=LyleRussell;1867959]I had the same issue. My Ford dealer went nuts finding what was wrong but eventually came up with a service note on it. There is no voltage on the truck pin unless there is a load on it. That's done so we don't short out the truck battery if snow or water gets into the connector. To prove this is correct measure the trailer battery voltage when disconnected. Then connect and start the truck. The voltage should be higher on the trailer battery.[/


Thank you.
The truck connector wouldn't show power on a meter or a 7 pin test light. I am thinking it needs some feed back voltage to activate.
Naper is offline   Reply With Quote
Old 10-23-2016, 07:22 PM   #5
2 Rivet Member
 
2011 27' FB Classic
Camp Hill , Pennsylvania
Join Date: Jul 2015
Posts: 75
Naperville that's the exact experience that I had. Try my test. It's true of 2015 and newer. There is a fuse but it was installed at the factory. The relay is now built in.

Try my test to see if I'm right.
LyleRussell is offline   Reply With Quote
Old 10-23-2016, 08:34 PM   #6
2 Rivet Member
 
2011 27' FB Classic
Camp Hill , Pennsylvania
Join Date: Jul 2015
Posts: 75
Naper sorry about my autocomplete function.
LyleRussell is offline   Reply With Quote
Old 10-24-2016, 02:45 PM   #7
Rivet Master
 
Naper's Avatar
 
2017 30' Classic
Loretto , Ontario
Join Date: Oct 2010
Posts: 507
Yep you are correct. Plugged in to the truck started the engine and sure enough it was charging. It would be helpful if Ford mentioned this in the owners manual.
__________________

Naper is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar charge controller affect charge from converter? fran&frank Electrical - Systems, Generators, Batteries & Solar 1 03-22-2016 10:39 PM
dead dead bolt Jim from SB Doors & Locks 3 09-09-2012 11:32 AM
Charge wire on 7-pin, what demands does AS need and how does this charge starcraft Batteries, Univolts, Converters & Inverters 10 04-20-2012 08:38 AM
Full Charge - No Charge! Cracker Batteries, Univolts, Converters & Inverters 2 06-22-2007 02:04 PM
Dead ...really dead Melody Ranch Batteries, Univolts, Converters & Inverters 17 06-13-2007 12:23 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
×