Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2013, 10:20 AM   #1
2 Rivet Member
 
1979 31' Sovereign
Stephenville , Texas
Join Date: Mar 2013
Posts: 21
Images: 2
1979 31' Sovereign - 100% n00b - Bringing it back to life

Greetings!

Let me start off by saying I am completely new to the travel trailer world.

The reason I decided to buy one is my current living arrangements are about to change and I needed a low cost living situation while I live out the remainder of my stay in my college town. I purchased an Airstream because I have heard lots of praise about them over the years and I came across this '79 for a heck of a price, IMO.

Now that I got it, I need to make it road worthy again. It was last inspected in June of 2007 and since that time it has sat along the side of a barn.
The owners (2 guys, both brothers) took really good care of it and I think it has aged well for a 30+ year piece of equipment.

1st things first, though, getting it roadworthy to get it to its new location. I'm having trouble getting the rear lights to work. None of the lights worked on the initial plug in to my truck. After pulling the covers and cleaning contacts, the lights work when they want to or with a little persuasion. Ive purchased all new bulbs yesterday evening after tinkering with them and will try them today when I get off work but I feel many of the bulb bases are too far gone to be 100% reliable.

Does anyone know where I can find replacements?

Also, the fuse box at the front of the cabin has quite a bit of corrosion on them, and there is a fuse missing. The fuse missing is on the far left. Is there a corrosion eliminating spray I can hit the fuse panel with or am I going to have to wire brush each individual wire and contact?
Do the wires for the lights run through the ceiling of the cabin?

Also, what kind of brakes does it have and is there anything I should look for as far as getting those in good working order. I havent hooked up to it yet so I dont know if they work or not.

Any input is greatly appreciated.

Thank you!
__________________

__________________
Gasgano1979 is offline   Reply With Quote
Old 03-21-2013, 07:46 AM   #2
2 Rivet Member
 
1979 31' Sovereign
Stephenville , Texas
Join Date: Mar 2013
Posts: 21
Images: 2
Well after some heavy cleaning and all new bulbs, the rear lights work....kinda. Reverse doesn't work still and the running and turn flashers work when they want. And whenever I hit the brakes, they cut off completely and I have "fire" on all 7 wires after the main plug. I think I have a bad ground somewhere. Can someone please point me in the direction of the trailer light ground on my AS?
__________________
Gasgano1979 is offline   Reply With Quote
Reply

Tags
sovereign


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -6. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.
Modal Click