Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-17-2013, 07:55 PM   #1
2 Rivet Member
 
S.Chance's Avatar
 
Tonganoxie , Kansas
Join Date: Feb 2011
Posts: 20
Electrical help!!

My wife and I bought our 1984 excella and when we were at the dealer they had it plugged in and all the electrical worked (lights, fan, electric jack, etc.) now that we're home the 12 volt doesn't seem to work (probably needs a new battery) but I have plugged it the 120 volt electrical into a plug in our barn and nothing will come on. No lights, the jack won't work, nothing. Is there a switch somewhere I need to flip or something? I have looked at the breaker panel inside the trailer and all the breakers are set to on. Any ideas? Thanks!!!
__________________
S.Chance is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.