Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-13-2013, 08:09 PM   #1
1 Rivet Member
 
2005 19' International CCD
Roswell , Georgia
Join Date: Oct 2006
Posts: 18
pump sounds/low pressure/culprit

On a recent trip, we had an issue where the pump sounded funny and we really couldn't get enough water pressure from the pump for it to be worthwhile. Last night, while winterizing, I believe we found the culprit (see pic). We could not pump antifreeze until we removed this. After that, all was good.

What is this item and what is the recommended maintenance regime?
Attached Thumbnails
Click image for larger version

Name:	WaterPump1_01.jpg
Views:	109
Size:	95.9 KB
ID:	199912  
__________________

__________________
joelbert is offline   Reply With Quote
Old 11-13-2013, 09:42 PM   #2
Rivet Master
 
aftermath's Avatar
 
2006 25' Safari FB SE
Spokane , Washington
Join Date: Sep 2009
Posts: 1,133
I believe that thing is the pre pump filter. It is there to prevent damage to your pump. I don't know what you meant by "we removed this" but if that worked perhaps you need to clean the filter.

I took mine off once to clean it but it really didn't need any cleaning.
__________________

__________________
aftermath is offline   Reply With Quote
Old 11-13-2013, 09:46 PM   #3
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
It is the pump filter, and is required by the pump manufacture. If it changed your pressure situation, it will need to be cleaned and/or replaced. They can be taken apart to clean.
__________________
idroba is offline   Reply With Quote
Old 11-13-2013, 10:17 PM   #4
4 Rivet Member
 
thehandyman's Avatar
 
1980 24' Caravelle
corpus christi , Texas
Join Date: Jul 2013
Posts: 263
Could be sucking air in through the filter. Check to see if the o ring is in good shape and seated correctly.
__________________
thehandyman is offline   Reply With Quote
Old 11-14-2013, 05:44 AM   #5
1 Rivet Member
 
2005 19' International CCD
Roswell , Georgia
Join Date: Oct 2006
Posts: 18
Thanks!

Ok, we will disassemble it, inspect it and clean it. In the spring, when we put it back on, we will see if it is still an issue.

If so, we will find out how to replace it. Anyone have a part number or link to purchase a new one?
__________________
joelbert is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.