Thread Tools Search this Thread Display Modes
Old 06-02-2014, 04:04 PM   #1
Teton Stream's Avatar
2013 20' Flying Cloud
Wilson , Wyoming
Join Date: Jul 2010
Posts: 62
Need Guidance

I installed an accumulator in my 2013 Bambi (right next to the pump). Checked out as advertised. Let it sit with pump on for three days to check for any leaks. Came in today (day three), no leaks and turned on water, full pressure. As it bled off the pump did not start. Turned off power, check fuse, turned on power pump started and charged system, stopped (ever so gradually as with accumulator). Ran water again and system bled down with no pump activation. Rocked the pump switch a couple of times and pump came on. No rhyme or reason to the number or frequency of on/off's to get pump to work.

Any thoughts besides bad pressure sensor on a 7 month old pump?

Teton Streamer - in The Toaster
Wilson, WY 83014
Teton Stream is offline   Reply With Quote
Old 06-02-2014, 06:04 PM   #2
Rivet Master
Larry C's Avatar
1996 34' Excella
Elberta , Alabama
Join Date: Oct 2006
Posts: 665
Did it work OK before you installed the accumulator?

Old age is coming at a really bad time!

1996 34' Excella 1000, interior totally redone, 2003 Dodge/Cummins HO, Diablo tuner, 115 gallon aux fuel, Bedslide, Airsafe/Reese Dual Cam, and a bunch of other stuff
Larry C is online now   Reply With Quote
Old 06-02-2014, 07:36 PM   #3
4 Rivet Member
Bigventure's Avatar
2013 25' FB International
Currently Looking...
Hinckley , Ohio
Join Date: Sep 2009
Posts: 423
Images: 4
Accumulators are not recommend for use with the variable speed pumps in new trailers. Take out the accumulator, it's not needed.
If you could have a superpower, what would it be?

I chose America
Bigventure is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need guidance in Cincinnati nilesrob On The Road... 7 08-30-2011 08:52 PM
Need Guidance Joe O'D Member Introductions 3 06-01-2010 07:16 PM
Upgrading to New TV - Need Guidance Stephen Mick Tow Vehicles 45 11-09-2008 10:18 PM
Some Guidance nikshak General Repair Forum 11 03-15-2003 05:31 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.