Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-26-2011, 07:10 AM   #1
Rivet Master
 
Aviator's Avatar

 
1997 34' Limited
1970 27' Overlander
South of Atlanta , Georgia
Join Date: Sep 2009
Posts: 1,655
Images: 2
Monitor indicator help needed

I searched through the forum and couldn't find a thread directly addressing this so here goes,

We have a 1997 Airstream. The first couple of outing the tank monitor worked fine (this was one year ago). After about three camping trips, the black, drain, and fresh tank indicators stay on empty even when it is backing up in the shower!

For those with far more experience with this, where should I start?

Is it a dirty sensor in the tank?

Is it a wiring problem between the panel and tanks? Strange they would all go at the same time.

Is it a circuit board problem at the panel?

Does it sound readily fixable , or should I resign myself to the flashlight monitor method?
__________________

__________________
Craig and Carol
1997 34' Excella 1000
1970 27' Overlander, International
2009 Ford F150 5.4L
ProPride hitch with 1400# bars

AIR 41028
TAC GA-8
WBCCI 10199
Past President Southeastern Camping Unit (12)
Aviator is offline   Reply With Quote
Old 02-26-2011, 07:21 AM   #2
4 Rivet Member
 
deauxrite's Avatar
 
2007 27' Safari FB SE
Full Timers just passing through , Arizona for a couple of weeks and then on to Utah!
Join Date: Jun 2005
Posts: 325
I fought the same problem for two years. I read all of the advice, tried several "fixes" and finally decided that my flashlight worked better anyway. Good luck.
__________________

__________________
Living life on the Road
deauxrite is offline   Reply With Quote
Old 02-26-2011, 09:01 AM   #3
Rivet Master
 
HowieE's Avatar
 
1991 34' Excella
Princeton , New Jersey
Join Date: Aug 2003
Posts: 6,813
Images: 12
Generally the tank indicators fail showing fuller than they are and don't fail indicating equal amounts in both. That type of failure is from something deposited on the censer, paper or fat.

The fact that yours has failed at indicators and on empty would lead me to want to check the electrical system. Look for an open circuit.

Does the rest of the panel, gas tanks and battery, work normally?
__________________
WBCCI 12156 AIR 3144 WACHUNG TAC NJ6
2004 Excursion 4x4
1991 34 ft. Excella +220,000 miles, new laminated flooring, new upholstery, new 3200 lbs axles

HowieE is offline   Reply With Quote
Old 02-26-2011, 11:07 AM   #4
3 Rivet Member
 
mhilley's Avatar
 
2000 23' Safari
Vero Beach , Florida
Join Date: Jul 2010
Posts: 180
Been fighting a not working sensor system for at least 6 months now. If it is a Catcon there is an easy method for checking the sensors to see if they are working correctly. It entails plugging a specially made jumper and checking the voltage. If you have a Catcon and would like the info send me a note and I will send it to you. I think those telephome connectors they use commonly crud up and don't work correctly. I can check the black water system with a light but how do you check for fresh water?
__________________
mhilley is offline   Reply With Quote
Old 02-28-2011, 01:10 PM   #5
Wise Elder
 
Jammer's Avatar
 
2010 30' Classic
Vintage Kin Owner
South of the river , Minnesota
Join Date: Dec 2009
Posts: 4,119
As a system they are notoriously unreliable.

No easy answers and as with any electrical troubleshooting you'll have to check the connections one at a time. You'll probably end up replacing the sensors.
__________________
Jammer is offline   Reply With Quote
Old 03-02-2011, 02:11 PM   #6
Rivet Master
 
Aviator's Avatar

 
1997 34' Limited
1970 27' Overlander
South of Atlanta , Georgia
Join Date: Sep 2009
Posts: 1,655
Images: 2
Howie,

Yes, the LP and Batt (both) gauges indicate properly. The fresh tank is empty at the moment, so it is correct as it shows empty (not sure if it works though). The two waste tanks are the irritant. I don't mind if the fresh isn't working as it isn't that big of a deal when the tank empties, but when the waste fills.....that is a whole different matter!
__________________

__________________
Craig and Carol
1997 34' Excella 1000
1970 27' Overlander, International
2009 Ford F150 5.4L
ProPride hitch with 1400# bars

AIR 41028
TAC GA-8
WBCCI 10199
Past President Southeastern Camping Unit (12)
Aviator is offline   Reply With Quote
Reply

Tags
monitor panel, sensors


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looked at airstreams today.. Advice needed. mikeandnora Buyer Guidelines 45 02-10-2011 12:27 AM
custom build help needed tjr General Repair Forum 4 01-30-2011 01:05 PM
1978 23' Safari International info needed ktmmike1 1974 - 1979 Safari 4 01-19-2011 12:07 PM
Radio antenna needed? SilverHoot Audio, Video & TV 25 01-19-2011 12:01 PM
Courtesy parking or rental parking needed, Perris Valley, California skydiva Our Community 1 01-13-2011 07:13 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.