Thread Tools Search this Thread Display Modes
Old 04-30-2003, 08:05 PM   #1
3 Rivet Member
jim8860's Avatar
Join Date: Mar 2003
Posts: 137
Send a message via AIM to jim8860
Generator No Start

I just came back form my trip and here is my proplem. Before I left the generator work perfect. Drove 600 miles and parked in the finest hotel that I can find parking lot and fired up the old generator for about 3 hrs. All was well. Drove 250 more and park at the camp site. We lost the power at the site that night so I when to start the generator and no luck no start. So the next day I check every thing out an this is what I found. When I hit the "start" button I think from what I can tell there is a fuel pump that runs while I hold the start button on. Then I took a test light to the stud on the starter and ther was no power there. I check 2 fuses and the look good. Any ideas???

PS I have a 7.0 Onan generator in a 95 MH LY

jim8860 is offline   Reply With Quote
Old 04-30-2003, 09:21 PM   #2
Airstream Driver
PeterH-Airstreamer's Avatar

1997 30' Excella
1983 31' Airstream310
Austin , Texas
Join Date: Feb 2002
Posts: 3,099
Images: 51
Low on fuel? Most generators will run out of gas at 1/4 Tank level.

1983 310 Classic Motorhome
1997 30' Excella Trailer
AIR #13
PeterH-Airstreamer is offline   Reply With Quote
Old 04-30-2003, 10:53 PM   #3
4 Rivet Member
Join Date: Feb 2002
Posts: 334
Images: 3

I have never known a owens gen set but, there is a very famous gen co named Onan. The usual not run senario is low oil. There is a sensor in the oil pan that controls power to the fuel pump. Spin the starter and spray just a few whiffs of starting fluid at aircleaner.
Visit Idaho The people are great
FrankR is offline   Reply With Quote
Old 05-01-2003, 02:20 AM   #4
3 Rivet Member
jim8860's Avatar
Join Date: Mar 2003
Posts: 137
Send a message via AIM to jim8860
Typo on they name I had no idea how I typed that name. As for no start it do not even crank over . Oil is fine and gas is full . The starter motor does not even get 12 volts. If the motor did get 12 volts then the starter motor is bad. From what I have read it point to the fuses . I only found 2 and they are good. Is there any more may be off the generator but in the MH?
jim8860 is offline   Reply With Quote
Old 05-01-2003, 08:09 AM   #5
Rivet Master
LOST , Hawaii
Join Date: Jun 2002
Posts: 2,193
My Onan grounds to start/stop so if your fuel pump is running you have power and that part of the starting circuit should be ok. If there is no power at the starter with the start switch closed I would check the solenoid and board.

74Argosy24MH is offline   Reply With Quote
Old 05-02-2003, 03:05 PM   #6
Rivet Master
87MH's Avatar
1978 31' Sovereign
Texas Airstream Harbor , Zavalla, in the Deep East Texas Piney Woods on Lake Sam Rayburn
Join Date: Jan 2003
Posts: 2,435
Images: 292
Possible Stuck Switch

If you do identify the problem to be in the remote switches, check ALL of the remotes for proper operation. Just one of the remote switches stuck in the "Kill" position (or internally shorted) would pre-empt proper operation of the remainder of the switches.

"Suck it up, spend the bucks, do it right the first time."

WBCCI # 1113
AirForums #1737

Trailer '78 31' Sovereign

Living Large at an Airstream Park on the Largest Lake Totally Contained in Texas
Texas Airstream Harbor, Inc.
87MH is offline   Reply With Quote
Old 05-03-2003, 04:43 PM   #7
3 Rivet Member
jim8860's Avatar
Join Date: Mar 2003
Posts: 137
Send a message via AIM to jim8860
Well I check out the old generator and what I found is the circuit bord was bad.The cost of the bord was $172.00.Thanks John (74Argosy24MH) you were right!. All seems good now. Untill next trip. Jim

jim8860 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Engine Won't Start!! eraffety Mechanics Corner - Engines, Transmission & More... 41 07-05-2006 07:01 PM
Let's start with the Fridge.... GT1963 Refrigerators 6 03-03-2004 09:01 PM
Where to start? stellablu General Repair Forum 0 08-08-2003 01:02 PM
where do you start?? skip General Repair Forum 6 07-20-2003 06:27 PM
Aaaargh!!! Motorhome won't start!!!! AGAIN!!! eraffety General Motorhome Topics 14 01-19-2003 06:40 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.