Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-27-2006, 04:00 PM   #1
JBK
3 Rivet Member
 
JBK's Avatar
 
1986 34.5' Airstream 345
Grand Rapids , Up in the Nort' Woods of Minn.
Join Date: May 2006
Posts: 120
Battery isolator problem I think...

The batteries for the coach drained from running the furnace and the engine won't start. When I hit the key, it turned over once and then nothing. The tach is registering around 4K and moves with load like a turn signal turned on. (This really has me stumped.)
Isn't there an isolator that is supposed to keep this from happening or do I have to manually move the switch in the battery box?
What is the talk of a button located in the glove box?

Also, the genset fuel pump doesn't come on when I try to start it. If I jump the pump, it works. Is there a relay or fuse I should be looking at?

JB
__________________

__________________
86' 345 MH. Named "AirBus". The wife and I finally agree.
JBK is offline   Reply With Quote
Old 11-28-2006, 03:54 PM   #2
JBK
3 Rivet Member
 
JBK's Avatar
 
1986 34.5' Airstream 345
Grand Rapids , Up in the Nort' Woods of Minn.
Join Date: May 2006
Posts: 120
No reply on either of my questions?
JB
__________________

__________________
86' 345 MH. Named "AirBus". The wife and I finally agree.
JBK is offline   Reply With Quote
Old 11-28-2006, 06:06 PM   #3
4 Rivet Member
 
bobchevy89's Avatar
 
1977 24' Argosy 24
Inverness , Florida
Join Date: May 2006
Posts: 264
JBK check the grounds on the engine battery I had something simuler on mine .check all ground cables on the moho, batt to engine engine to frame frame to body.when all are disembled and cleaned all systems work better ,lights get brighter. batt gets full charge. works for me..
Bob
__________________
bobchevy89 is offline   Reply With Quote
Old 11-28-2006, 06:41 PM   #4
4 Rivet Member
 
bibbs's Avatar
 
1977 Argosy Minuet 6.0 Metre
1973 21' Globetrotter
1975 26' Argosy 26
Vista , California
Join Date: Sep 2006
Posts: 265
JB
I had the same thing happen on my Argosy,good clean grounds are important,in my case the isolation switch wasnt opening and thus draining both bateries. to test; disconect engine battery,put an ohm meter accros the switch[big red wires]should show no continuity when key is off [open] reconect battery and should be same reading. infinite with key on [closed]
I dont know where your isolation switch is located mine is inside the front engine compartment door,in a black plastic box,left hand side.
hope this helps

Bibbs
__________________
bibbs is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Location uwe 1970-79 Tradewind 23 12-02-2015 08:41 AM
Battery Slide Out niftypkg Electrical - Systems, Generators, Batteries & Solar 5 01-01-2003 04:41 PM
Second Battery w9det 1999 Safari 5 12-06-2002 07:42 PM
igniton switch and the mystery of the dead battery Curtis-79MH Airstream Motorhome Forums 3 10-25-2002 03:58 PM
Extra Battery Placement JaceBeck 1999 Safari 16 10-02-2002 02:03 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.