Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-15-2006, 05:53 PM   #1
1 Rivet Member
 
1993 35' Legacy Diesel
richmond , Michigan
Join Date: Aug 2006
Posts: 7
speedometer problem on a '93 legacy

I recently purchased a 93 Legacy this is a Cummins DP on a spartan Chasis. I have aproblem with the speedo that I knew about going into the deal.when you start the motor and at idle, the spedo needle jumps up to about 45 and then back down again. When driving it jumps and says aboy 75 when you are going about 45-50. Bottom line is something is not right. I remember that in the past a jumping speedometer ment that a cable was about ready to break. But with the jump at idle and not in gear I suspect it is something more like a ground or other electrical malfunction. Has anyone else experienced this problem?
__________________

__________________
1993 Legacy35 DP MH
Shadow & Duchess Furry Children
(Golden Retriever Therapy Dogs)
1997 Saturn Toad
Dog Trainer is offline   Reply With Quote
Old 08-15-2006, 07:31 PM   #2
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,191
You may have a bad wire going to the sensor, or the sensor is in the process of crapping out. Does the coach have ABS? I am guessing it has an Allison transmission. On some coaches of that year, there is a two-prong plug under the hood that goes to the speedometer, it may have corroded or gotten loose over time. Please let us have some more info, we can try to send you in a direction (hopefully the right one).
__________________

__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Old 08-15-2006, 08:50 PM   #3
1 Rivet Member
 
1993 35' Legacy Diesel
richmond , Michigan
Join Date: Aug 2006
Posts: 7
Thanks for your reply Overlander63. It does have an Allison Transmission and air brakes. This coach only has 35,000 on it so it has sat around a lot. Is the sensor on the transmission ? I know they used to be on the front wheel. The owner says the speedo was working fine but this coach had not been driven since oct 05 and then sat 3/05- 10/05. I know I need to go through it completely and change filters, fluids etc... before any miles are put on it.
__________________
1993 Legacy35 DP MH
Shadow & Duchess Furry Children
(Golden Retriever Therapy Dogs)
1997 Saturn Toad
Dog Trainer is offline   Reply With Quote
Old 08-19-2006, 05:21 PM   #4
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,191
The sensor may be at the rear of the transmission, or a part of the ABS (wheel speed sensor).
__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Potential Problem? Pictures included palmtreegirl 1990 - 1993 Excella 51 08-12-2013 11:50 PM
Interesting Tongue Jack electrical problem Wingeezer Jacks, Stabilizers, Lifting and Leveling 15 10-12-2012 11:08 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.