Thread Tools Search this Thread Display Modes
Old 09-23-2013, 05:51 PM   #1
Rivet Master
DaveFL's Avatar
2000 31' Land Yacht
Central , Florida
Join Date: Aug 2007
Posts: 1,472
Images: 15
Gas gauge stopped working P-30 chassis

Since last trip out, I either lost 1/3 of tank of gas or something else. Checked fuses all other gauges working and fuse good. Put in 15 gallons no change, gauge shows empty, didn't lose it. Nothing behind gauge to go wrong, wires enter by way of bundle. Must be the sending unit, now the hole I had cut for the fuel pump inspection last year will save time and effort. Lifted carpet, opened the hatch and spotted my problem, rodent made nest and needed a snack, purple wire chewed until disconnected from fitting about .5 inches from the 4 pole connector. Removed the nest material, insulation, chewed aluminum foil protecting area, used it to seal the insulation after cutting hole. Managed to clean wire, and have enough to solder the connection. Fixed.

Stopped any more chewing covered wire loom and connector with aluminum screen, took out the two teeth sharpening rocks mouse had brought to the nest, unless it was for the foundation she was planning to build.
Attached Thumbnails
Click image for larger version

Name:	P1000217.jpg
Views:	57
Size:	334.2 KB
ID:	196274   Click image for larger version

Name:	P1000218.jpg
Views:	53
Size:	244.0 KB
ID:	196275  


DaveFL is offline   Reply With Quote
Old 09-24-2013, 06:41 AM   #2
Rivet Master
92landyacht's Avatar
1992 36' Land Yacht
Grayson , Georgia
Join Date: Nov 2011
Posts: 772
Yep, rodent problems can get very bad. You may have gotten lucky. Just make sure they're all gone or you'll be revisiting them again. Look up a product called "Fresh Cab". Seems to have worked for me.
92landyacht is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dometic working on shore power, but difficult to get it running on gas Scott J-24 Refrigerators 28 12-22-2011 03:49 PM
Dometic not working on 12V, ok Elec & Gas afordjones Refrigerators 1 08-16-2011 06:02 AM
Master Lift Gas Springs ElliotA General Repair Forum 2 08-07-2011 09:45 PM
How can I fill my US Ali gas bottles with LPG in the UK??? shinny67 LP Gas, Piping, Tanks & Regulators 7 01-14-2011 09:42 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.