Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-05-2011, 08:45 PM   #1
New Member
 
2004 39' Land Yacht 390 XL 396
Bowie , Texas
Join Date: Jul 2009
Posts: 2
Losing engine elec. engine dies while driving

I lose electrical power just driving down the road. all light go out, no emerg. flasher... nothing until I turn the key off and back on a couple of time. Rough road, smoth road, up hill, down hill, doest mater. I think its a bad ground or bad ignition. Any ideas?
__________________

__________________
ccgartman is offline   Reply With Quote
Old 12-05-2011, 08:50 PM   #2
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,189
Welcome to the forum. If nothing works until you cycle the key, chances are good it's the ignition switch. Cleaning grounds and other connections won't hurt, either.
__________________

__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Old 12-05-2011, 10:30 PM   #3
Rivet Master
 
SteveH's Avatar
 
2005 39' Land Yacht 390 XL 396
Common Sense , Texas
Join Date: Sep 2007
Posts: 5,311
Not saying this the problem, but a friend of mine had a hot rod that did the same thing. Turned out to be a cold solder joint in the main battery ground cable to the block of the engine.

I would check all such cables/connectors/joints, including the ones on the ignition switch. The easiest way to find the problem would be with the engine running at idle, and wiggling wires/connectors to see if you can find one that makes it quit. Good luck, and welcome to the forum, CC.
__________________
Regards,
Steve
SteveH is offline   Reply With Quote
Old 12-05-2011, 10:39 PM   #4
Rivet Master
 
DaveFL's Avatar
 
2000 31' Land Yacht
Central , Florida
Join Date: Aug 2007
Posts: 1,478
Images: 15
Key or relay the key triggers, does it also kill engine, being diesel, old ones would go even if you didn't have alternator and batteries, new without electric the computer shuts it down. My guess would also be battery main ground if engine dies too.
__________________
DaveFL is offline   Reply With Quote
Old 12-10-2011, 09:46 AM   #5
New Member
 
2004 39' Land Yacht 390 XL 396
Bowie , Texas
Join Date: Jul 2009
Posts: 2
Thanks for the help. I found the problem. It was a 135 amp auto reset breaker located in the same box as the inverter. 15min ($40.00)replacement job.
__________________
ccgartman is offline   Reply With Quote
Reply

Tags
power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get to engine on rear diesel pusher? 442 john Land Yacht/Legacy Motorhomes 1 10-21-2011 11:26 AM
Replace engine in 95 LandYacht Diesel cjshaffer2 Land Yacht/Legacy Motorhomes 4 09-25-2011 08:40 PM
Driving Tips, '89 325 joelforeman Classic Motorhomes 8 09-19-2011 11:27 AM
Engine box Fasteners, Bolts, 1995 Cutter LE on Ford F53 Chassis BarnacleBill Land Yacht/Legacy Motorhomes 4 04-27-2011 04:41 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.