Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-14-2016, 06:52 PM   #1
2 Rivet Member
 
1988 34.5' Airstream 345
Camarillo , California
Join Date: May 2016
Posts: 28
Blog Entries: 1
1988 345 leveling jacks won't deploy

Leveling jacks worked 3 months ago, but won't work now. Doesnt even seem to be taking any current. fuse looks good. Is there another fuse?
__________________

Ripley345 is offline   Reply With Quote
Old 11-19-2016, 03:38 PM   #2
Rivet Master
 
bkahler's Avatar

 
1974 20' Argosy 20
Richmond , Kentucky
Join Date: Jan 2003
Posts: 7,838
I doubt if there is another fuse. You might look for a solenoid close to the hydraulic pump or mounted directly on it.

First thing would be to see if any voltage is getting to that solenoid when you try and lower the jacks. If no voltage then you'll have to start back tracking from there.

If there is voltage you might try tapping on the solenoid. If that doesn't work then try replacing the solenoid. If that doesn't do it then the only thing left is the pump.

Do you have the wiring diagram for the jacks?

Brad
__________________

__________________
Air forums # 1674
1974 20' Argosy Motor Home
1974 31' Excella trailer (parting out, as of 4/1/2015 I have wheels, brake drums, windows & holding tanks left to sell)
bkahler is offline   Reply With Quote
Old 11-20-2016, 05:34 AM   #3
3 Rivet Member
 
1986 34.5' Airstream 345
Alliance , Ohio
Join Date: Apr 2007
Posts: 242
If your system was made by HWH you can find manuals and info on their website at hwhcorp.com.


Sent from my iPad using Airstream Forums
mehes is offline   Reply With Quote
Old 11-20-2016, 07:37 PM   #4
2 Rivet Member
 
1988 34.5' Airstream 345
Camarillo , California
Join Date: May 2016
Posts: 28
Blog Entries: 1
Smile Problem solved.... kind of

Turns out I had an electrical problem. Funny thing was I couldn't detect the problem in the leveler switch box. So I cut the wire to the ignition, hot wired into another switch. While doing that I noticed the other end of the leveling switch wire from the ignition was now hot. So i wired back into that and all is good. But now my dash lights, turn signal and back up are out. 4 way flashers working. Going to start a new post.

Thank you all for your advice.

Ripley345
Ripley345 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stablizer jacks replacement with scissor jacks spoonplug Jacks, Stabilizers, Lifting and Leveling 18 11-25-2018 06:22 AM
Jacks won't deploy on 1988 345 Ripley345 Land Yacht/Legacy Motorhomes 4 11-18-2016 04:39 PM
Motorhome steps deploy while moving! Pomfritz Steps 9 08-22-2010 09:29 AM
Step is difficult to deploy - Help! mello mike Steps 8 08-20-2010 08:44 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
×