Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-15-2014, 06:18 PM   #1
1 Rivet Member
 
Join Date: Dec 2014
Posts: 7
1000W Inverter not working even with full battery

Can anyone help me identify why my inverter in airstream international 19 doesn't work. The battery is fully charged and when I turn on the inverter via the remote switch it will turn on for a few seconds and then shutoff the inverter shows error code E04. Any ideas?
__________________

__________________
corymac is offline   Reply With Quote
Old 12-15-2014, 06:20 PM   #2
Rivet Master
 
2011 25' FB Flying Cloud
Anywhere & , Everywhere
Join Date: Aug 2006
Posts: 1,090
When you looked up the error code in the inverter manual what did it say?
__________________

__________________
Al - K4GLU is offline   Reply With Quote
Old 12-15-2014, 06:22 PM   #3
1 Rivet Member
 
Join Date: Dec 2014
Posts: 7
I don't think it had the exact code but it did say a red led light indicates inverter failure
__________________
corymac is offline   Reply With Quote
Old 12-15-2014, 06:23 PM   #4
Rivet Master
Commercial Member
 
lewster's Avatar
 
Vintage Kin Owner
Naples, FL , Hood River, OR
Join Date: Dec 2005
Posts: 7,281
A bit more detail would help a lot. What type and manufacturer of inverter do you have? Which batteries and how large is their capacity?
__________________
Lew Farber...ABYC Certified Master Marine Electrician...RVIA Certified Master Tech ...AM Solar Authorized Installation Center...AIRSTREAM Solar & Electrical Specialist...Micro Air 'Easy Start' Sales and Installations
lewster is offline   Reply With Quote
Old 12-15-2014, 06:25 PM   #5
1 Rivet Member
 
Join Date: Dec 2014
Posts: 7
2 12v batteries deep cycle I think
__________________
corymac is offline   Reply With Quote
Old 12-15-2014, 06:27 PM   #6
1 Rivet Member
 
Join Date: Dec 2014
Posts: 7
Manufacture is WFCO electronics I believe the model is WF-5110 H
__________________
corymac is offline   Reply With Quote
Old 12-15-2014, 06:35 PM   #7
Rivet Master
Commercial Member
 
lewster's Avatar
 
Vintage Kin Owner
Naples, FL , Hood River, OR
Join Date: Dec 2005
Posts: 7,281
IIRC, E04 is an overload fault. You can't repair any WFCO product like you can with the Magnum units, but an overload can indicate a bad internal component (AC board, etc.) or is simply indicating that an event occurred and a hard reset is needed.

A hard re-set is accomplished by removing all power (both AC and DC) from the inverter for 15 minutes. Re-connect and try to operate it again. If the error code persists, your inverter is toast!

Smell anything burning?
__________________
Lew Farber...ABYC Certified Master Marine Electrician...RVIA Certified Master Tech ...AM Solar Authorized Installation Center...AIRSTREAM Solar & Electrical Specialist...Micro Air 'Easy Start' Sales and Installations
lewster is offline   Reply With Quote
Old 12-15-2014, 06:44 PM   #8
1 Rivet Member
 
Join Date: Dec 2014
Posts: 7
So just to be sure are you saying I should disconnect the batteries and reconnect them after 15 minutes and that may reset the inverter?
__________________
corymac is offline   Reply With Quote
Old 12-15-2014, 07:14 PM   #9
Rivet Master
Commercial Member
 
lewster's Avatar
 
Vintage Kin Owner
Naples, FL , Hood River, OR
Join Date: Dec 2005
Posts: 7,281
Quote:
Originally Posted by corymac View Post
So just to be sure are you saying I should disconnect the batteries and reconnect them after 15 minutes and that may reset the inverter?
Yep.
__________________
Lew Farber...ABYC Certified Master Marine Electrician...RVIA Certified Master Tech ...AM Solar Authorized Installation Center...AIRSTREAM Solar & Electrical Specialist...Micro Air 'Easy Start' Sales and Installations
lewster is offline   Reply With Quote
Old 12-16-2014, 08:25 PM   #10
2 Rivet Member
 
drftboat's Avatar
 
2012 16' Sport
2015 19' Flying Cloud
Seattle , Washington
Join Date: Oct 2014
Posts: 25
I recently, a couple months ago, took delivery of a 2015 19FC. Just as you described the inverter did not work once the remote (wall switch) was pushed and green light on. I read the manual, called WFCO and they confirmed 1) a red light was bad (failure) and 2) asked me to isolate and test. I bagged it and returned to the dealer. The dealer was Johnny on the spot and quickly determined that the unit was bad and replaced it. Your situation sounds identical to mine. Exercise your warranty. Hope this helps.
__________________

__________________
drftboat is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1000w inverter for Dometic Rm3762 GammaDog Electrical - Systems, Generators, Batteries & Solar 16 11-14-2014 10:18 AM
Help! Battery not charging, outlets not working when plugged in AirGal04 Electrical - Systems, Generators, Batteries & Solar 9 06-06-2014 10:15 PM
600w vs 1000w inverter SilverEagle6 Batteries, Univolts, Converters & Inverters 14 12-02-2013 07:38 PM
1000w+ solar Airstream Darkspeed Generators & Solar Power 26 08-19-2011 11:41 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.